Portfolio 21 not impacted by internet security bug, "Heartbleed"

April 11, 2014

Recent news reports have raised concerns regarding an internet security vulnerability, known as the “Heartbleed bug” that affects software called Open Secure Sockets Layer Architecture (OpenSSL). This vulnerability only affects certain types of servers running specific versions of the OpenSSL encryption application.  Portfolio 21’s online account and paperless document management systems do not use this technology and are not impacted.

While Portfolio 21’s systems are unaffected, we take the security of your personal data very seriously.  We recommend choosing a unique password for each website you use and changing that password every 90 days.

Notice

I understand and would like to proceed. »